Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[INFORMATION](4/11/2024)
Cubism Editor 5.1 alpha2 is now available!

We have incorporated some of your comments and suggestions. Thank you for your comments and requests!
We will continue to welcome your feedback on alpha2.

Download/ Manual and Update History

RAM Capping at 2G

I have 48GB of RAM, i upgraded my RAMs just so i can use Live2D with less lag and freezing. While I'm meshing parts of the model, After a while, Live2D starts to lag A LOT. I have to wait at least 10-15 seconds every time i put a dot down. But when i check the Task Manager, it shows that Live2D is only using 2G of my RAM, It never passes 2G. I upgraded my RAMs just for Live2D and searched for a solution on the net, but couldn't come up with anything. How do i let Live2D use more of my RAM so i don't have to wait? It takes so much time for me to hand-mesh important parts and it affects how fast i finish a commission.

I've posted about this on the Discord Community, and did some troubleshooting with other people;

1- We checked the Log for any type of errors. (none found, only some warnings about the Back Up Save)

2- Checked the Java Version;
- It was 1.8.0
- We Updated the Java, didn't change anything
- We deleted and re-installed the latest version, didn't change anything.
- We changed the Java Heap Size, didn't change anything.

3- I've checked around the forum to see if anyone had similar problems, They did. The issue they had found was Java's default Options restricting/overriding Live2D's. So I read the replies and found fix, But the Fix they had didn't change anything on my end.

4- I've sent the files I am currently working with (Please note that this issue is not new, I had this issue for a while now. With different files.) and send the cmo3 file to another friend to see if they have the same issue (which is lagging due to RAM capping) And they had no issues (our PC Specs are very similar.) They had no problem running the program around 30G of RAM while my Live2D capped at 2G (I have 48G RAM in total)

- After the Troubleshooting, Live2D Started to Cap around 1G RAM. I have to wait at least 20-25 seconds to do anything.

None of the troubleshooting helped, updating the java caused Live2D to Cap around 1.7G Not even being able to go up at 2G. I have deadlines and can't continue with the speed I need to be able to finish my products before the deadline with this issue.
Please Help.
Thank You.


- Live2D Software Version: 5.0 (Had the Same issue on 4.x But it wasn't this severe, It would cap at 5G)
- OS & Version: (Windows 10)
- PC Model: (Desktop with Asus Motherboard)
- Graphics Specifications: (RTX 2060)
- CPU: (AMD Ryzen 5 3600)
- Memory: (48GB)
- Illustration Software used: (ClipStudioPaint)
Tagged:

Comments

  • @NamiAthena

    Thank you for always using our products.

    The fact that the memory is limited to 2GB means that something is preventing Cubism from allocating memory correctly when it starts up. The cause is unknown and has not been reproduced in our environment.
    To avoid this, you need to open the folder where Cubism Editor is installed and edit the bat file.
    Open CubismEditor5.bat in a text editor and delete the characters "rem" on lines 13 and 14. Then add "rem" to line 15.
    Next, rewrite the "MAX_MEMORY" number specified on line 14 in megabytes.
    If you want to use 8GB of memory as a sample, it should look like this.

    rem ** Memory Size
    set MAX_MEMORY=8000
    set MAXMEMORY=-Xmx%MAX_MEMORY%m
    rem set MAXMEMORY=-XX:MaxRAMPercentage=100

    After that, start CubismEditor from the edited CubismEditor5.bat or exe.
    Just in case, I have attached a sample bat file.

Sign In or Register to comment.