Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[INFORMATION](4/11/2024)
Cubism Editor 5.1 alpha2 is now available!

We have incorporated some of your comments and suggestions. Thank you for your comments and requests!
We will continue to welcome your feedback on alpha2.

Download/ Manual and Update History

I can't Export my moc3 file. what should I do? pls help me.

I have worked on a project with a file size of 3.2 GB and this is the biggest project for me. export won't start and keeps stuck on 'saving', this lasts for 1 hour (sometimes more). export file stops but I don't get the file (moc.3). I've made several attempts like this (deleting unused layers and folders, reducing the artmesh structure, and reducing the atlas). Does the number of PSD affect exports?
when finished export, I get ERROR in my Log, like the following:

[ERROR] java.lang.ArrayIndexOutOfBoundsException
[ERROR] at com.live2d.serialize.archiver.RandomAccess$b.a(Unknown Source)
[ERROR] at com.live2d.serialize.archiver.ArchiveWriter.writeHeader(Unknown Source)
[ERROR] at com.live2d.serialize.archiver.ArchiveWriter.writeToBytes(Unknown Source)
[ERROR] at com.live2d.serialize.UUSerialize.serializeToBytes(Unknown Source)
[ERROR] at com.live2d.serialize.UUSerialize.serializeToBytes$default(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.x$a.a(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.x$a.a(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.x.a(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.b.a(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.b.a(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.f.a(Unknown Source)
[ERROR] at com.live2d.cubism.doc.model.exporter.f.invoke(Unknown Source)
[ERROR] at com.live2d.util.ad.a(Unknown Source)
[ERROR] at com.live2d.util.af.run(Unknown Source)
[ERROR] at java.lang.Thread.run(Unknown Source)

Live2D Software Version: Cubism Editor 4.2.04 Pro
OS & Version: Windows 10 Pro 64-bit (10.0 Build 19045)
Video card: Nviidia GeForce RTX 2060 Super
CPU: Intel Core i5-10400F
Memory(RAM): 32GB
Illustration Software used: ClipStudio

Please help me, its so important for me.

Comments

  • @ferdifisi

    Thank you for always using our products.

    You also sent us an email with similar content, didn't you?
    We will skip replying to your email.
    We would appreciate it if you could post only in the community from now on.
    In the community, official staff may also reply to posts that they believe need support, such as possible bugs.

    We have checked the model file you sent us and it seems that the problem is caused by the very large file size.
    We are distributing official sample models, so please refer to the number of deformers and art meshes and the size of textures for modeling.
    https://www.live2d.com/en/download/sample-data/

    Model information can be viewed under "Model Statistics" in the File menu.
    https://docs.live2d.com/en/cubism-editor-manual/file-menu/#:~:text=all dialog boxes.-,Model Statistics,-Display the model

    Best regards.
  • @Enoko(Staff)

    thanks for replying to my discussion.
    so what should i do is reduce the number of deformers, artmeses and overall texture size? won't it affect other components? like rigging, animation, physics, etc?
  • Hello @Enoko(Staff)
    i've done reduced warp deformer (which is not connected to parameters), reduced vertices and polygons. after saving the file size is reduced, from 3.2 GB to 2.88 GB.
    I tried to re-export the file, unfortunately the export doesn't work at all and it stays in the "saving" tab it lasts for more than 1 hour. is there any other way to fix this?
    I really appreciate your help.

    this is the difference in the total number in Model Statistics.
    which initially:
    << Common Data >>
    Number of Parts : 297

    << Deformer Data >>
    Number of Warp Deformers : 712
    Number of Rotation Deformers : 60
    Number of Interpolations in Deformers : 3727

    Number of Deformers with Only One Draw Element : 282
    Number of Deformers with Only One Deformer : 169
    Number of Deformers with No Content : 3

    << ArtMesh Related >>
    Number of ArtMesh : 830
    Number of Interpolation ArtMesh : 2906
    Number of Vertices : 94639
    Number of Polygons : 149350
    Number of ArtPath:0
    Number of ArtPath's control points:0

    <<Relating to Clipping Masks>>
    Clippings used: 349
    Mask ID permutation types: 53
    Objects with moc3 output issues: 0


    be like this:
    << Common Data >>
    Number of Parts : 297

    << Deformer Data >>
    Number of Warp Deformers : 490
    Number of Rotation Deformers : 60
    Number of Interpolations in Deformers : 3765

    Number of Deformers with Only One Draw Element : 153
    Number of Deformers with Only One Deformer : 146
    Number of Deformers with No Content : 1

    << ArtMesh Related >>
    Number of ArtMesh : 829
    Number of Interpolation ArtMesh : 2977
    Number of Vertices : 78241
    Number of Polygons : 121536
    Number of ArtPath:0
    Number of ArtPath's control points:0

    <<Relating to Clipping Masks>>
    Clippings used: 349
    Mask ID permutation types: 53
    Objects with moc3 output issues: 0
  • thank you for helping me, my problem is solved. the problem is too many PSD files.
Sign In or Register to comment.