Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Sonoma 14.0] (update 10/17/2023)
The current compatibility status with released Live2D Cubism products is as follows:
[supported]Live2D Cubism Editor version 5.0.01 and later
[not supported]Live2D Cubism Editor version 5.0.00 beta1 and earlier,Other Live2D Cubism products, including Live2D Cubism SDK.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details

Can't save model file, "Requested Array Size Exceeds VM limit"

edited December 2023 in Help
Hello, Live2D

I've encountered a problem: the model file does not save after I copy-paste a bunch of deformers and art meshes.
It gives me either error "Requested Array Size Exceeds VM limit" or "Out of heap space".
I've tried different live2d versions: 4.02.04beta5, released version 4.02.03_2, and 5 alpha.
The issue persisted in all versions equally, though the error message in alpha was different:




My pc ram is 64, max ram allowed through .bat file is 32000, I've also tried to add a variable for Java ram which made Live2D work faster but did not resolve the issue.

After manually narrowing down the amount of copied items, I was able to copy 80% of them and found out the problem still persists if I copy 2 deformers with 2 of their child meshes inside. I need 6 copies total of the same item and 4 other times copying everything worked perfectly but was bugged with the remaining two.

Do you have any suggestions what might be causing the issue and maybe we can resolve it together?
I'm worried that the problem will reappear later on with the same model file, as I have just started it and it has not much yet going on.

Comments

Sign In or Register to comment.