Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Sonoma 14.0] (update 10/17/2023)
The current compatibility status with released Live2D Cubism products is as follows:
[supported]Live2D Cubism Editor version 5.0.01 and later
[not supported]Live2D Cubism Editor version 5.0.00 beta1 and earlier,Other Live2D Cubism products, including Live2D Cubism SDK.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details

Cubism SDK for unity r.6 can not work with Unity on Apple Silicon

edited December 2023 in Help
SDK: CubismSdkForUnity-4-r.6
Unity: 2021.3.18 (Apple Silicon based)

I created an empty project and import cubism sdk, the error shows up:
Live2D CubismCore is not loaded, Please reboot this Unity project if it is just after import of the SDK. If it's not, please check if platform settings of dll is correct. dll cannot be used on platform which is different from its own build settings.

Also I can not preview any sample models, thousands of error like:
This .moc3 file version is "Unknown"!!
It may be broken or you are trying to use a higher version of Moc than Cubism Core.

DllNotFoundException: Live2DCubismCore assembly: type: member:(null)
Live2D.Cubism.Core.CubismLogging.Initialize () (at Assets/Live2D/Cubism/Core/CubismLogging.cs:54)


Comments

Sign In or Register to comment.