Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Sonoma 14.0] (update 10/17/2023)
The current compatibility status with released Live2D Cubism products is as follows:
[supported]Live2D Cubism Editor version 5.0.01 and later
[not supported]Live2D Cubism Editor version 5.0.00 beta1 and earlier,Other Live2D Cubism products, including Live2D Cubism SDK.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details

Live2D Editor won't open, goes unresponsive and freezes on Mac

Currently, I have been using the newest version of Live2D (Testversion) on my MacBook Pro and it all has worked pretty good until two days ago after I did a macOS update (from Monterey 12.3.1 to Monterey 12.4). When I tried to open it, the launch screen appeared but the program went unresponsive so I had to force quit it every time. I've tried reinstalling Live2D and installing the beta and older versions but the problem remains.

I worked a way around it by setting Live2D to open whenever I restart my Mac and that works! I can work with it until I try to synthesize the corners. Then the program freezes again and I have to force quit it.

Here are my specs:

- Live2D Software Version: Cubism Editor 4.0.05
- OS & Version: macOS Monterey 12.4
- PC Model: MacBook Pro (16-inch, 2019)
- Graphics Specifications: AMD Radeon Pro 5300M 4 GB
Intel UHD Graphics 630 1536 MB
- CPU: 2,6 GHz 6-Core Intel Core i7
- Memory: 16 GB 2667 MHz DDR4
- Illustration Software used: Photoshop

Comments

  • Hello, @Maus
    Thank you for your contact.
    We apologize for any inconvenience this may cause.

    If possible, could you please provide the following?
    ・Log files
    ・Error reports to be displayed upon forced termination
    ・Screen recording showing the problem

    【How to get the log file】
    Open Cubism Editor, click [Help] in the menu at the top of the screen, and then click [Open Log File] to open the log file and attach it.

    If you don't want the data to be public, please send it via DM.

    [How to send a direct message]
    Click on my name, "kudo(Staff)".
    My profile screen will open. Click on [Message] in the top right corner.
    The message sending screen opens.
    Click on the icon [Attach file] and select the file.
    Click [Post Message] to send the message.
    (Please compress the file. If the file is too large to be attached, use an upload site or similar)

    We appreciate your cooperation
    Thank you.
  • Hi, @Maus
    Thank you very much for the movie and other information.

    We have checked the files.
    Could you please check the following.

    Do you use multiple monitors such as pen tablets?
    Please disconnect all devices connected to your PC and restart your PC.
    After that, could you please close all resident applications such as drivers for pen tabs, etc., and then start Editor?

    ※Resident applications and the Cubism editor may interfere with each other.
    https://docs.live2d.com/cubism-editor-manual/faq/?locale=en_us (Q28)

    Is there any change if I start the Editor while offline?

    We appreciate your cooperation
    Thank you.
  • edited June 2022
    @kudo(Staff) I don't have anything connected to my Mac.
    I have uninstalled my pen tablet drivers and restarted my Mac but the problems are still the same. Also, no changes when I start the Editor offline.
  • Hi, @Maus
    Thank you for your check.

    Please delete the following configuration folder and check the behavior of the Editor.
    【Mac】
    /Users/[User name]/Library/Live2D/Cubism4_Editor/

    Also, could you please restore the mac's standard fonts by referring to the following.
    ※If you have added fonts, you will need to add them again after checking Editor.
    https://help.live2d.com/en/cubismeditor/cubism-editor-ui-texts-are-garbled/
  • @kudo(Staff) I've deleted the Cubism4_Editor-folder but the program still goes unresponsive when opening.
    And I have restored my Macs standard fonts, but still no change.
  • HI, @Maus
    thank you for your try.

    Could you please let us know your current status so that we can assess the situation.
    1.Is the Editor now able to be started in the usual way?
    2.Is the Viewer available without any problem?
    (e.g., opening a sample model in the Viewer)
    https://www.live2d.com/en/download/sample-data/

    3.Does the Editor crash randomly while in use?
    4.Is there still a problem with the automatic generation of the four corners not working?
    5.How about the latest beta version (Cubism Editor 4.2 beta2)?
    https://www.live2d.com/en/download/cubism/

    6.I heard that you upgraded macOS before the problem occurred. Do you remember performing any other operations such as installing applications?

    We appreciate your cooperation
    Thank you.
Sign In or Register to comment.