Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Sonoma 14.0] (update 10/17/2023)
The current compatibility status with released Live2D Cubism products is as follows:
[supported]Live2D Cubism Editor version 5.0.01 and later
[not supported]Live2D Cubism Editor version 5.0.00 beta1 and earlier,Other Live2D Cubism products, including Live2D Cubism SDK.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details

Live2D Editor loads, but crashes when opening any file type

Hello there,

I have an issue where the Live2D Editor crashes 100% of the time upon opening any of these types of files: CAN3, CMO3, even PSD. I have tried many different files from older and more recent projects. I have confirmed that the files are not corrupt, by installing Live2D on another device and opening them successfully there.

Configuration:
- Live2D Cubism Editor v4.1.01 (but I also downgraded to 4.1.00 and upgraded to 4.1.02 beta1, same results)
- 2012 Macbook Pro, MacbookPro9,2, i5 2.5GHz, 16GB RAM, 500GB SSD
- Catalina 10.15.7 (highest possible for this Mac, it's possible this issue started happening after upgrading to 10.15.7, but I am not certain).

I have also tried completely deleting Live2D from the Application folder, and reinstalling, with the same results.

Can you give me some tips on other things to try? Shall I share some logs? Are there other configuration files stored in system folders that I should try deleting to get a truly fresh install?

Thanks.
Tagged:

Comments

  • I think I am having the identical issue to Jaiden087, also on a Macbook.
    Here is my log file, the crash happens at the exact same point as in their log.
  • Hello, @ja3robin
    Thank you for your contact.
    This is Live2D Support.
    We apologize for any inconvenience this may cause.

    Please delete the following configuration folder and check the behavior of the Editor.
    【Mac】
    /Users/[Username]/Library/Live2D/Cubism4_Editor/

    Intel GPUs are running; if your PC has a GPU that is not onboard, change it in the settings.
    What GPU are you using?

    Please check if this also happens in Cubism Editor 4.0.09.
    https://www.live2d.com/en/download/cubism/

    We appreciate your cooperation
    Thank you.
  • Thank you for the reply.

    1. I tried deleting the /Users/[Username]/Library/Live2D/Cubism4_Editor/ folder, and the program still crashes upon opening a model.

    2. I am running Intel HD Graphics 4000 1536 MB on a Mid-2012 MacBook Pro. (see screenshot)


    3. I downgraded and tried with Cubism Editor 4.0.09. The program still crashes upon opening a model. (log file attached).

    I'm beginning to suspect that it is the upgrade to macOS Catalina 10.15.7 that coincides with the beginning of this problem.

    Are you by chance able to reproduce on a Mid-2012 MacBook Pro hardware running the latest Catalina 10.15.7?

    Thanks.
  • Hello, @ja3robin
    This is Live2D Support.
    Thank you for your information and log file!

    Could you please provide us with the model(cmo3) file for our research?

    Could you please try the following conditions:
    1.Disconnect all devices from the PC.
    2. reboot and then close all startup software.
    3. screen record the Editor's behavior
    (Please check with the official sample model.)
    https://www.live2d.com/en/download/sample-data/

    Also, does Cubism Viewer work properly?
    (Please check with the official sample model.)
    https://www.live2d.com/en/download/sample-data/
  • - Yes, here are a few sample models (PSD, CMO3, CAN3) in a Zip file. It crashes when I open any of these.

    - I also tried your recommended steps of disconnecting all devices, rebooting, and closing any other running software. The software still crashes when trying to open any models.

    - I downloaded the sample-data (rice_pro_en) model.
    The software crashes in the same way when trying to open either the can3 or cmo3 files.

    - I also tried opening the moc3 file in the viewer, and it also crashes.

    - I have attached a screen recording of this for your review.

    - And also the log.txt file that corresponds to the above tests (and crashes).
  • Hello, @ja3robin
    This is Live2D Support.
    Thank you for providing a variety of data.

    After discussing it with the developer, the problem could not be identified on the Editor side.
    So you are right, it could be a problem with the OS or a problem with an update.
    It may be cured by reinstalling the OS, etc.

    hope that helps!
    Thank you.
  • (SOLVED)

    I have some good news to report, my issue is now resolved!

    The freezing problem resolved itself upon installing "macOS Catalina Security Update 2021-008" which was just released Dec 13, 2021.

    Attached is a screenshot of my Software Installations history.


    Recap:
    - The freezing problem started Nov 16th after installing Security Update 2021-007.
    - The freezing problem resolved Dec 21st after installing Security Update 2021-008.
    - Machine: 2012 MacBook Pro (MacbookPro9,2, i5 2.5GHz, 16GB RAM, 500GB SSD, Intel HD Graphics 4000)
    - OS: Catalina 10.15.7, which is the highest macOS revision possible to install.

    Hopefully this information helps others experiencing the same problem.

Sign In or Register to comment.