Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Sonoma 14.0] (update 10/17/2023)
The current compatibility status with released Live2D Cubism products is as follows:
[supported]Live2D Cubism Editor version 5.0.01 and later
[not supported]Live2D Cubism Editor version 5.0.00 beta1 and earlier,Other Live2D Cubism products, including Live2D Cubism SDK.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details

Problem with exporting and importing parts from Live2D 4.0 to Unity SDK

I recently started using Live2D (Version 4.1.01) to make some animations for a class project I'm working on in Unity (Version 2021.1.1.6f1). I am using a Windows 10 for this as well. I've been following Live2D's documentation for exporting and importing very closely and have already imported Live2D's Unity Package to my Unity project file. I have a link to my Live2D project files here and a link to the embedded model SDK files I've been uploading to Unity here.

The problem is when I upload my model to Unity, everything in the inspector of the model prefab looks right according to the reference models provided by the Live2D Unity Package- except none of the parts show up under the "Cubism Parts Inspector" script. The model doesn't even render when I drop it into a Unity scene, which I am hoping is related to this so that both issues can be solved at once.

I'm not sure if I'm missing a step in embedding my model data or what but if anyone has experienced this and can help I would really appreciate it, I would be bummed if I couldn't include this animation in my project but I may need to abandon it if I can't figure it out in a timely manner. Let me know if you need more info on my part-

In Unity, here's a photo of what the reference model included in the package looks like

Under "Cubism Parts Inspector, you can see a list of all of the example model parts in the inspector



Here's a photo of what my model looks like, you can see the outline of the object but no rendered materials in game view

However, the model looks how it should when I open the prefab

Under "Cubism Parts Inspector", there are no parts listed

Even in the hierarchy, no parts show up as children of the "Parts" parent object that should be holding them



Thanks in advance!

Comments

Sign In or Register to comment.