Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this forum.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[INFORMATION](6/25/2024)
Cubism Editor 5.1.00 beta1 is now available!

We have incorporated some of the feedback we received from those who tried the alpha version.
Thank you very much for your comments and requests!
All alpha versions will soon be closed to the public and will no longer be available.
Also, the Cubism Editor 5.1 alpha category will be closed, so please send your comments and requests to the Cubism Editor category.
Options

[Unity] Texture not showing

I followed the steps that were showing in this link
https://docs.live2d.com/cubism-sdk-tutorials/getting-started/

However, when I imported my model file it seemed to have some problems on the texture.

First, I did export the file as moc3 file and inputted in the Assests folder. However, the texture didn't show up, so I thought it was the prefabs problem.

Next, I changed it to an prefab by inputting it in to the Prefab folder. Then it seemed to change to a prefab.

Still it didn't added any textures to the object. Can anyone help me with this problem?

I will show some pictures of my exported file and my current unity project scene.





Am I doing it in the wrong way or is there something wrong with the system?

Comments

  • Options
    Hello, @padosory5 .
    Thank you for your contact and report.

    Are the texture files in the folder of the model you want to import?
    As far as I can tell from the image, the texture file used for the model does not exist.
    If you want to use the Cubism model in the SDK, you need a texture file.
    If it is not in the folder, please re-import it including the texture file.

    If poking around the texture file does not solve the problem, could you please provide me with a minimal project that reproduces the phenomenon for me to investigate?
    The project should be sent to me as an attachment to the Community DM.

    Thanks.
Sign In or Register to comment.