Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this community.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
 
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
"[NOTICE]" About the support for Mac models
Cubism Editor is not supported with Apple M1 processors.
Please refer to System Requirements for details.
We will not respond to any related inquiries with this message.
Please note that Cubism SDK is not supported with Apple M1 processors and macOS 11.0 Big Sur.
Live2D user has created a tutorial video(unoffilcial) in English. SEE ALSO.
Thank you, brian_tsui!
[Live2D Tutorial 2020] Introduction to Tools and Technical Concepts

HELP: Meshes in Texture Atlas are too small for some parts

This is my first time using live2D so im not sure what the problem is but I have attached a screenshot.



for some parts, you can see that the image size is only within the parts size (eg. head/mouth) but for some other parts (eg. eyes/hoodie) its calculated as a full canvas size which is probably why when i try to create a texture atlas some of them are too small. (see screenshot)



so for some unknown reasons its calculating those parts size as the whole canvas size rather than only the part itself.

Would really appreciate any help ^^

-------------------------------------------------------------------------------------------------------
im using live2D version 4.0.08 on windows
software that i used to bring in the model is photoshop

Comments

  • edited March 18
    ok i kinda fixed half of the issue myself

    idk why but when i checked my psd file and click CTRL-T it was showing the full canvas but when i click enter n CTRL-T again, the borders fit the part. so i just select all my layers n did CTRL-T -- enter -- CTRL-T -- enter.

    so when i reimport, on the layers it shows only within the parts boundary but when i try to create texture atlas, its still the same problem

    send help TvT

  • ok welp it works when i just import the model to a new file and redo all the auto mesh thing.

    but if anyone knows hw to fix the issue to the same file instead of doing on a new file do let me know ^^
  • I faced this same issue. I made my drawing in Procreate and exported it as PSD, and when I generated the texture Atlas, each layer was the size of the canvas. I then opened the PSD file in Krita and erased the white background layer (I don't know if this did anything, just saying all I did), and saved it as another PSD file. When I opened the new file in Live2D and generated the texture atlas the issue was solved. It seems some programs that export their files as PSD will face this issue, but Krita (which is free) doesn't. Hope this works for you and anyone else facing this problem!
Sign In or Register to comment.