Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Dear Users,

Now, we are seeking users who can give us a hand with expertise to evolve our software more dynamically.
If you are willing to help us, we’d like you to make a registration for “Live2D Creators Circle” via the link below.
Designers, programmers, translators are especially welcomed so far.
(More detailed explanation will be given to you before we ask you to do tasks)

https://docs.google.com/forms/d/1G5KK_GL3ozwPXtTHrpi_ktbsI8UZf8jlYRSlDworyBo/viewform?usp=send_form

Having trouble with texture resizing

I was hoping I wouldn't have to post again so soon, but I'm working on a new character and I'm having trouble with the Resize Ratio when importing the PSD.

With my first character the resize ratio was at 100%. With the new chara I'm using the same PSD size, roughly the same body size, I work the same way as before - yet I can't get the resize ratio past ca. 85%, which makes the file blurry in the modeller. At the same time there is free space when the texture is generated. I tried fitting the parts into a texture manually and there's enough space.

I was going to replace the texture with this manual one and remap the parts, but for that I'd need a guide image. But when I import a guide image of the same size, it turns out completely pixelated. So it's not precise enough to rearrange the parts and I'm not sure its' size is correct.

Of course I can provide the files I work with if need be - thanks a bunch in advance! ( ^ ^)7

Comments


  • i opened a new PSD in my modeler and this is the default settings for me, maybe you can match yours to those and see if it works:



    1- the PNG will be this size, so the bigger your pc can handle the better, but if it's too big there will be too much empty space.
    2- the margin between layers: when i increase it, the parts get farther and father apart which if it got too big might not fit into the one PNG
    3- offsetting for re-import: kinda does the same but with the top-down margins and left-right margins controlled separately
    4- this part is my own fault, both sides of a lab coat are on one layer, so they get rendered as one single part. i should have made those into two different layers in photoshop (left_coat and right_coat for example) if you have anything you can break up into separate layers try to do that, maybe something is too big in there.

    another idea: once you've imported the texture, make sure you are zoomed in at 100%, and then go to the top buttons: Show > High Quality Mode
    did any of those work?
  • @PeakJump
    I was hoping I wouldn't have to post again so soon (..)
    As you don't have to pay per post, just feel free to ask and comment to other threads as well :# .


    I think first trying renoa's suggestion is the way to go. If that doesn't help, read on...


    The problem you are facing is that the summed size of all psd layers you are trying to import is to big for a single texture. In such cases the editor shrinks your layers down, which will result in the blurriness you describe. There exist two workarounds for that limitation. Both require the use of multiple textures for your model.

    1) When you re-import a psd, all new layers are automatically added to a new texture. If you add layers to your psd and import them in steps so that for each step the summed size of the layers are within the size limit for a single texture, you will always be able to import at 100%. This isn't very straightforward, however.

    2) Reposition your parts onto a new texture so that no layers have to be shrunken by the editor. Again, renoa posted a nice vid on how to reposition parts here.
  • Thanks for the responses guys (and sorry for this late answer)! I think I found a (somewhat weird) solution ^^

    I should've mentioned - I'm working with the free version (I missed the sale in january T-T).

    I double-checked all the settings you mentioned Renoa. I was trying them out before as well, it changed the resize ratio a bit, but not enough to reach 100%. High quality mode was a bust as well unfortunately.

    Then I turned to the points Andi described (And Renoa's cool vid). I can see how the first solution might work, but true, it would be a bit time-consuming ^^' (tho at this point I'd gladly use it)

    Now the repositioning part gave me an idea. As I've understood it the repositioning is a PRO feature, right? So for now that's not an option I can use.

    So what I did is I took the texture png I made myself in Photoshop, so all the parts fit in 100%, and saved that as a one-layer PSD. Then I imported that into the blurry chara. Luckily the modeller registered all the parts separately. So I'm using the blurry chara as a guide image and positioning the new parts accordingly. All the parts are named texture_01, but that's not such a big problem ^^.

    That'll also take some time to set up, but as long as it works I'm happy =P - so it's still a bit too soon to see if it works flawlessly, but it's looking good so far. I'll let you guys know once I'm done and if it works. Thanks again for all the helpful input ^^7
  • @PeakJump

    Wow, that solution really sounds kinda weird :# . Let us here how it worked out.

    I missed the sale in january T-T
    I'm not quite sure how the pricing was during the sale in January, but an indie license for the editor is still available. If your new to Live2D, using the free version surely is an option though, I think.
Sign In or Register to comment.