Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please limit one question/topic per post.
Please provide the following details depending on types of question

▼ For question regarding Editor, please provide:
- Live2D Software Version: (e.g. Cubism Editor 3.1.02, Euclid Editor 1.2.02)
- OS & Version: (e.g. Windows 10, macOS HighSierra)
- PC Model: (e.g. MacBookPro 2017)
- Graphics Specifications: (e.g. GeForce GTX 950M)
- Memory: (e.g. 8GB)
- Illustration Software used: (e.g. Photoshop, ClipStudio, SAI)
- Attach screenshot or capture video to show your problem:
▼ For question regarding SDK, please provide:
- For us to reproduce the issue you wish to inquire about, please provide either a minimum project file which has the issue. or specific instructions on how to reproduce the issue.
- Types and version of Cubism SDK you are using.
▼ For question regarding Cubism Software License,
For issues related to purchasing, your order, license key, and subscription, please contact us via contact form:

Can't switch amongs .mtn in TyranoBuilder

edited April 2018 in Help
Hi, hello everyone.

First, after learned how to use Live2D and follow the steps and sucessfully load the right .json (using SDK 1.0/2.0 to export the .moc file) on TyranoBuilder, I got this problem:

All my three .mtn motion files load fine after added the right .json on Tyrano but when I try to switch among the .mtn files to check if they are OK, Tyrano just shows and animates the first one made with Animator in an infinte loop.

Don't matter how much I click on other .mtn files, Tyrano just animates the first one, even when I tried to change in the L2D component field to another motion file the issue still. If I check the loop box the animation freezes forever.

Load the same .mtn files on Viewer to check if I have saved the same animation 3 times, but they worked fine there.

I don't know if I'm doing something wrong or it's an issue with TB or L2D.

Second question: In the model sample Nasuka, its .mtn files are in a 'motion' folder, textures are a folder called nasuka, how to save my files like that ???

Because when I load nasuka model .json on Tyrano I can change among the .mtn files and maybe this can help me.

Here is the link on Tyrano site if you want to see what I mean:

Thanks for any help.


  • Update:

    Before dragging them onto Viewer I've put all files in a folder named motions, exported the model.json and loaded it on Tyrano and this happened:

    First .mtn becomes the idle motion automatically and I can change among the motions now, then I set the idle motion to be the one I want to.

    BUT...everytime I add L2D character in the game it first plays one of the motions in backwards (?) then plays the idle motion, keeps happening just with my files, still not getting this issues using the samples from Tyrano and L2D sites. :/

    Anyone having a similar problem ?

Sign In or Register to comment.