Dear Users,

Now, we are seeking users who can give us a hand with expertise to evolve our software more dynamically.
If you are willing to help us, we’d like you to make a registration for “Live2D Creators Circle” via the link below.
Designers, programmers, translators are especially welcomed so far.
(More detailed explanation will be given to you before we ask you to do tasks)

Question about importing model

So I'm working with cubism 3 and unity. I have the SDK imported and tried to import my model. I dragged my model folder into unity asset, and a new gameobject was created in the scene and seemed to work. But there was no prefab being created, and when I tried to created a prefab out of the gameobect automatically created, the prefab I made failed to display the model.

Because there is barely any tutorial around, I think I may misunderstood the whole process of importing models. Help would be appreciated!


  • And there is an error message saying that "UnauthorizedAccessException: Access to the path 'Assets/Live2D/Cubism/PA2048/' is denied."

    PA2048 is the name of my file's folder.
  • Hi starless,

    Could you please provide the following information?

    -Version of Unity
    -Version of Live2D Cubism 3 SDK

  • My unity version is Unity 2017.1.1f1, 64 bit.
    And I tried to run it on 5.6, the same problem occurred as well.

    My cubism 3 SDK is Cubism30SdkUnity-4.

    Thanks for your time.
  • Hi,

    Thank you for your reply.

    With that environment, we'd like you to do the followings and to see the same issue still happens.

    - After importing SDK into Unity, reboot the same Unity project.
    - Before importing a model, change CubismUnityComponents to the latest one published on GitHub.

  • Alright...Thank you, it worked.

    But I ran into a new problem.
    So the prefab it automatically created, the drawing order of it cannot be set to correct. I changed the drawing order to Back to Front Order, and it worked in the scene. But every time I imported it into the scene, the order was wrong, and I need to change it to the same setting to get the correct rendering.
    But I need to access the prefab through script and it won't come out as the correct order.
    Is there a solution for that issue?

    Thank you for your help!
  • I have the same problem. I've already tried 'reboot Unity project' and 'change CubismUnityComponents to the latest one published on GitHub'.

    UnauthorizedAccessException: Access to the path 'Assets/Model/' is denied.

    It's still unresolved.
  • Hi guys,

    Now we are working to identify the cause of this issue. It would be much appreciated if you could give us a bit more time.

  • Hi @starless @103221 ,

    In order to identify the cause, could you please let us know the following information?

    - What kind of process were you trying to do when this error happened.
    - Did you import the model data in one time?
    - Do you use Cubism30SdkUnity-4? If you use other version, we'd like to know.
    - Is it possible for us to see the model data for tests?

    Thank you in advance for your assistance.
  • Also @starless,

    Regarding drawing order problem, we'd like to know which camera projection you use.

Sign In or Register to comment.