Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this community.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
Live2D user has created a tutorial video(unoffilcial) in English. SEE ALSO.
Thank you, brian_tsui!
[Live2D Tutorial 2020] Introduction to Tools and Technical Concepts

Can't put my own character on Unity, help please :)

Hi, I use Unity 4.5 on a mac
I created my own character and just create simple motion for testing and learning purposes.
I have added the "bytes" extension to moc, json and mtn files
I use the Live2D_Canvas from SDK, copied all the files and maintaining the structure.
and after I set my json to the script and run it, it says :
NullReferenceException: Object reference not set to an instance of an object
LAppModel.loadModelData (System.String modelFile, System.String[] texFiles) (at Assets/Scripts/sample/LAppModel.cs:193)
Which was :
193. live2DModel = Live2DModelUnity.loadModel(modelMoc.bytes);
I'm not sure what I did wrong, but if I switch it to "shizuku's" json file (copied and run from my own Unity project), it worked fine. So I decided to open both Json file using Text Edit and saw a difference on the top of the file.
Mine has different path (no path at all), and also it says "type : Live2D model setting", while Shizuku does not have that.
tried re-doing, re-export, ,re-trace all the steps, but none worked, I must have overlooked or missed something.

Can anyone help?


Sign In or Register to comment.