Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please limit one question/topic per post.
Please provide the following details depending on types of question

▼ For question regarding Editor, please provide:
- Live2D Software Version: (e.g. Cubism Editor 3.1.02, Euclid Editor 1.2.02)
- OS & Version: (e.g. Windows 10, macOS HighSierra)
- PC Model: (e.g. MacBookPro 2017)
- Graphics Specifications: (e.g. GeForce GTX 950M)
- Memory: (e.g. 8GB)
- Illustration Software used: (e.g. Photoshop, ClipStudio, SAI)
- Attach screenshot or capture video to show your problem:
▼ For question regarding SDK, please provide:
- For us to reproduce the issue you wish to inquire about, please provide either a minimum project file which has the issue. or specific instructions on how to reproduce the issue.
- Types and version of Cubism SDK you are using.
▼ For question regarding Cubism Software License,
For issues related to purchasing, your order, license key, and subscription, please contact us via contact form:

Can't put my own character on Unity, help please :)

Hi, I use Unity 4.5 on a mac
I created my own character and just create simple motion for testing and learning purposes.
I have added the "bytes" extension to moc, json and mtn files
I use the Live2D_Canvas from SDK, copied all the files and maintaining the structure.
and after I set my json to the script and run it, it says :
NullReferenceException: Object reference not set to an instance of an object
LAppModel.loadModelData (System.String modelFile, System.String[] texFiles) (at Assets/Scripts/sample/LAppModel.cs:193)
Which was :
193. live2DModel = Live2DModelUnity.loadModel(modelMoc.bytes);
I'm not sure what I did wrong, but if I switch it to "shizuku's" json file (copied and run from my own Unity project), it worked fine. So I decided to open both Json file using Text Edit and saw a difference on the top of the file.
Mine has different path (no path at all), and also it says "type : Live2D model setting", while Shizuku does not have that.
tried re-doing, re-export, ,re-trace all the steps, but none worked, I must have overlooked or missed something.

Can anyone help?


Sign In or Register to comment.