Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this community.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
"[NOTICE]" About the support for Mac models
Cubism Editor is not supported with Apple M1 processors.
Please refer to System Requirements for details.
We will not respond to any related inquiries with this message.
Please note that Cubism SDK is not supported with Apple M1 processors and macOS 11.0 Big Sur.
Live2D user has created a tutorial video(unoffilcial) in English. SEE ALSO.
Thank you, brian_tsui!
[Live2D Tutorial 2020] Introduction to Tools and Technical Concepts

Deform Brush Tool is not working


So for a few days now, my deform brush tool has not been working.
I thought it would fix itself at some point, but I'm working on a new project and now it's become a hindrance.
I have tried everything and I can't figure out why this is happening.

I have created new projects and tried different PSD's. I have also uninstalled and reinstalled Cubism 4.1 multiple times.
I have tried the tool on 4.1 beta as well and nothing.
I have tried to cclean everything and tried installing on a different drive thinking it's a file in my pc. Nothing.
I have tried the tool on a deformer and directly on the artmesh. Nothing.
I am losing my mind on this. It doesn't make sense that every Live2d file and 4.1 and 4.1 beta both don't work.

The only thing I can recall doing when this tool stopped working is doing a copy paste shape (ctrl+shift+c/v) or trying different conversion divisions and this windows popped up:

I clicked OK 'cause there were no real red flags and after that the tool no longer worked.
I have tried reverting the divisions back to default and like I said, tried different PSD's. Nothing is working.

Here's a sample of me trying to use the tool on a deformer:

Video Sample

Any help is appreciated.


  • Hello, @itsnovaj.
    Thank you for your contact.
    This is Live2D Support.

    Please check to see if the art mesh or deformer is not locked.

    If that doesn't fix it, please send us the log file and the model file.
    What part of the model did you move (dayformer, art mesh, etc.) when using the deform brush tool?

    Please follow the instructions in the attached image to get the log file.

    [How to send a direct message]
    Click on my name, "kudo(Staff)".
    My profile screen will open. Click on [Message] in the top right corner.
    The message sending screen opens.
    Click on the icon [Attach file] and select the file.
    Click [Post Message] to send the message.
    (Please compress the file. If the file is too large to be attached, use an upload site or similar)

    We appreciate your cooperation
    Thank you.

  • Hello, @itsnovaj
    This is Live2D Support.

    We have confirmed a bug that the Transformation Brush tool does not work properly when it is made too small.
    (It is recommended to use it at 15pt or more).

    Also, please note that the Transform Brush tool works on the points of the mesh, so if the points are not within the range, the mesh will not be transformed.

    hope that helps.
    Live2D Support
Sign In or Register to comment.