Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please limit one question/topic per post.
Please provide the following details depending on types of question

▼ For question regarding Editor, please provide:
- Live2D Software Version: (e.g. Cubism Editor 3.1.02, Euclid Editor 1.2.02)
- OS & Version: (e.g. Windows 10, macOS HighSierra)
- PC Model: (e.g. MacBookPro 2017)
- Graphics Specifications: (e.g. GeForce GTX 950M)
- Memory: (e.g. 8GB)
- Illustration Software used: (e.g. Photoshop, ClipStudio, SAI)
- Attach screenshot or capture video to show your problem:
▼ For question regarding SDK, please provide:
- For us to reproduce the issue you wish to inquire about, please provide either a minimum project file which has the issue. or specific instructions on how to reproduce the issue.
- Types and version of Cubism SDK you are using.
▼ For question regarding Cubism Software License,
For issues related to purchasing, your order, license key, and subscription, please contact us via contact form:

Problem using Unity SDK


I've been following this tutorial ( and have run into a problem repeatedly.

In the tutorial the Live2D_Canvas object uses the script LApp Model (Script), where as the included files use LApp Model Proxy (Script) which does not seem to allow me to link my model.json, instead asking for a path.

Including the path to the model instead gives me the following error:

NullReferenceException: Object reference not set to an instance of an object

Attempting to attach LApp Model (Script) to the game object produces an error also.

I'm using the most recent SDK and unity version (I also tried the older SDKs, same problem), and I'm on windows 7 64bit.

Thanks in advance for any help!


  • Sorry, the tutorials are outdated. LAppModelProxy is indeed the correct one.

    Like you wrote, I understand that it does not allow you to link your model.json by drag&drop, instead asking for a path. This is due to the current settings of the SDK, and you will need to manually type in the path to your model.json . Sorry for the hassle, but this is the simple solution at the moment.

    We are actually in the middle of modifying both SDK along with relevant tutorials, which are to be released in the next update.
  • Hello, could you possibly give an example of what that path should look like? I've tried typing in:
    • (whatever goes before this)\Resources\live2d\shizuku\shizuku.model.json
    • (whatever goes before this)\Resources\live2d\shizuku\shizuku.model
    • (whatever goes before this)\Resources\live2d\shizuku
    however none of it seems to work.
  • ok nevermind. I went into the sample version that Live2D provides and saw that the path was live2d/shizuku/shizuku.model.json.
  • TodTod
    edited January 2015
    Glad you solved by yourself.
    Thank you for sharing!
Sign In or Register to comment.