Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this community.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Ventura 13.0] (12/20/2022)
The currently released Live2D Cubism SDK is not guaranteed to work with macOS Ventura.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details
About the support for Mac models
Cubism Editor is not supported with Apple M1 processors.
Please refer to System Requirements for details.
We will not respond to any related inquiries with this message.

Can't put my own character on Unity, help please :)

Hi, I use Unity 4.5 on a mac
I created my own character and just create simple motion for testing and learning purposes.
I have added the "bytes" extension to moc, json and mtn files
I use the Live2D_Canvas from SDK, copied all the files and maintaining the structure.
and after I set my json to the script and run it, it says :
NullReferenceException: Object reference not set to an instance of an object
LAppModel.loadModelData (System.String modelFile, System.String[] texFiles) (at Assets/Scripts/sample/LAppModel.cs:193)
Which was :
193. live2DModel = Live2DModelUnity.loadModel(modelMoc.bytes);
I'm not sure what I did wrong, but if I switch it to "shizuku's" json file (copied and run from my own Unity project), it worked fine. So I decided to open both Json file using Text Edit and saw a difference on the top of the file.
Mine has different path (no path at all), and also it says "type : Live2D model setting", while Shizuku does not have that.
tried re-doing, re-export, ,re-trace all the steps, but none worked, I must have overlooked or missed something.

Can anyone help?


Sign In or Register to comment.