Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

If you have any questions, reports, suggestions, or requests about Live2D, please send them to this community.
※We cannot guarantee statements or answers from Live2D staff. Thank you for your understanding in advance.
Live2D Cubism
Cubism Products and Downloads
Cubism product manuals and tutorials
Cubism Editor Manual    Cubism Editor Tutorial    Cubism SDK Manual    Cubism SDK Tutorial
[About macOS Ventura 13.0] (12/20/2022)
The currently released Live2D Cubism SDK is not guaranteed to work with macOS Ventura.
Please refrain from upgrading the macOS as they may not work properly.
The Cubism Editor license file may be lost after the macOS upgrade.
Please make sure to deactivate the Cubism Editor license before upgrading the macOS.
For more details
About the support for Mac models
Cubism Editor is not supported with Apple M1 processors.
Please refer to System Requirements for details.
We will not respond to any related inquiries with this message.

Problem using Unity SDK


I've been following this tutorial ( and have run into a problem repeatedly.

In the tutorial the Live2D_Canvas object uses the script LApp Model (Script), where as the included files use LApp Model Proxy (Script) which does not seem to allow me to link my model.json, instead asking for a path.

Including the path to the model instead gives me the following error:

NullReferenceException: Object reference not set to an instance of an object

Attempting to attach LApp Model (Script) to the game object produces an error also.

I'm using the most recent SDK and unity version (I also tried the older SDKs, same problem), and I'm on windows 7 64bit.

Thanks in advance for any help!


  • Sorry, the tutorials are outdated. LAppModelProxy is indeed the correct one.

    Like you wrote, I understand that it does not allow you to link your model.json by drag&drop, instead asking for a path. This is due to the current settings of the SDK, and you will need to manually type in the path to your model.json . Sorry for the hassle, but this is the simple solution at the moment.

    We are actually in the middle of modifying both SDK along with relevant tutorials, which are to be released in the next update.
  • Hello, could you possibly give an example of what that path should look like? I've tried typing in:
    • (whatever goes before this)\Resources\live2d\shizuku\shizuku.model.json
    • (whatever goes before this)\Resources\live2d\shizuku\shizuku.model
    • (whatever goes before this)\Resources\live2d\shizuku
    however none of it seems to work.
  • ok nevermind. I went into the sample version that Live2D provides and saw that the path was live2d/shizuku/shizuku.model.json.
  • TodTod
    edited January 2015
    Glad you solved by yourself.
    Thank you for sharing!
Sign In or Register to comment.