Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Please limit one question/topic per post.
Please provide the following details depending on types of question

▼ For question regarding Editor, please provide:
- Live2D Software Version: (e.g. Cubism Editor 3.1.02, Euclid Editor 1.2.02)
- OS & Version: (e.g. Windows 10, macOS HighSierra)
- PC Model: (e.g. MacBookPro 2017)
- Graphics Specifications: (e.g. GeForce GTX 950M)
- Memory: (e.g. 8GB)
- Illustration Software used: (e.g. Photoshop, ClipStudio, SAI)
- Attach screenshot or capture video to show your problem:
---------------------------
▼ For question regarding SDK, please provide:
- For us to reproduce the issue you wish to inquire about, please provide either a minimum project file which has the issue. or specific instructions on how to reproduce the issue.
- Types and version of Cubism SDK you are using.
---------------------------
▼ For question regarding Cubism Software License,
For issues related to purchasing, your order, license key, and subscription, please contact us via contact form:
https://www.live2d.com/en/contact/contact_form

Rendering level problem!!

I got a problem about rendering level.

First, watch this pictures.




When i use normal diffuse shader. Everything was ok. I could change red frame in front of or behind the live2d model.

But, the live2d model is on the top when i use transparent/diffuse shader.No matter how i change model always on the top.

How can i solved this problem?

Forgiving my poor english!
1.png 334.2K
2.png 356.2K
Tagged:

Comments

  • Hi KevinHo,

    Rendering of Live2D models is done by calling DrawMeshNow function. However, if you render it with any other object that has some level of transparency, Live2D model ignores the depth information and ended up rendered on top of everything even if the other object is placed on top of Live2D model.

    To solve this, we advise you to use DrawMesh function instead of DrawMeshNow function.

    You can see some explanation here (in Japanese)
    http://sites.cybernoids.jp/cubism2/sdk_tutorial/platform-setting/unity/csharp/render-mode

    Also, the latest version of the SKD for Unity (v2.0.01_1) has some bug for your case, so I recommend using a previous version v2.0.00_1
  • Following the tutorial. I got another problem!


    sdk version: v2.0.00_1
    camera: orthographics
    live2DModel.setRenderMode(Live2D.L2D_RENDER_DRAW_MESH)
    3.png 346.4K
  • Ah, you are seeing the model from the back.

    It's a bit confusing, but each texture faces front regardless of angle of camera. So if you see a model from from back, DrawOrder will be inverse, but each texture seemingly faces front.

    So I advise you to either turn the model around 180 degree or move the camera around 180 degree.
Sign In or Register to comment.